Mobile app users having auth issues
Incident Report for SalesCandy
Postmortem

What Happened?

A minor bug was discovered and fixed in our authentication service which changed a particular data type from a number to a string type. After testing, the fix was deployed yesterday evening.

However, an authentication function that belonged to the websockets service was overlooked; where it had depended on the bug to work correctly; in effect, it stopped working when it unexpectedly received data in the correct type. The error was discovered after users had reported that their mobile app was unable to connect to websockets.

The function has now been corrected and appear to be working normally now.

Posted Jan 15, 2023 - 14:41 GMT+08:00

Resolved
This incident has been resolved.
Posted Jan 15, 2023 - 14:35 GMT+08:00
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2023 - 14:22 GMT+08:00
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 15, 2023 - 14:08 GMT+08:00
Investigating
Users are reporting authentication errors and we are seeing elevated error rates from our auth system.
Posted Jan 15, 2023 - 13:53 GMT+08:00
This incident affected: Mobile Application (Authentication (Logins)).